Docker Toolbox - Container unresponsive


#1
2018-10-19 10:07:50.026  INFO 9952 --- [ XNIO-2 task-13] c.s.docker.client.DefaultDockerClient    : Starting container with Id: 1a754a5ee11ffb2b2220fe46620a8f8b86a263e83bfe04bc1cac846e37299cd7
2018-10-19 10:07:54.294  WARN 9952 --- [ XNIO-2 task-13] e.o.shinyproxy.ShinyProxyTestStrategy    : Container unresponsive, trying again (2/10): https://192.168.99.100:20000
2018-10-19 10:07:56.301  WARN 9952 --- [ XNIO-2 task-13] e.o.shinyproxy.ShinyProxyTestStrategy    : Container unresponsive, trying again (3/10): https://192.168.99.100:20000
2018-10-19 10:07:58.309  WARN 9952 --- [ XNIO-2 task-13] e.o.shinyproxy.ShinyProxyTestStrategy    : Container unresponsive, trying again (4/10): https://192.168.99.100:20000
2018-10-19 10:08:00.316  WARN 9952 --- [ XNIO-2 task-13] e.o.shinyproxy.ShinyProxyTestStrategy    : Container unresponsive, trying again (5/10): https://192.168.99.100:20000
2018-10-19 10:08:02.323  WARN 9952 --- [ XNIO-2 task-13] e.o.shinyproxy.ShinyProxyTestStrategy    : Container unresponsive, trying again (6/10): https://192.168.99.100:20000
2018-10-19 10:08:04.331  WARN 9952 --- [ XNIO-2 task-13] e.o.shinyproxy.ShinyProxyTestStrategy    : Container unresponsive, trying again (7/10): https://192.168.99.100:20000
2018-10-19 10:08:06.338  WARN 9952 --- [ XNIO-2 task-13] e.o.shinyproxy.ShinyProxyTestStrategy    : Container unresponsive, trying again (8/10): https://192.168.99.100:20000
2018-10-19 10:08:08.347  WARN 9952 --- [ XNIO-2 task-13] e.o.shinyproxy.ShinyProxyTestStrategy    : Container unresponsive, trying again (9/10): https://192.168.99.100:20000
2018-10-19 10:08:10.356  WARN 9952 --- [ XNIO-2 task-13] e.o.shinyproxy.ShinyProxyTestStrategy    : Container unresponsive, trying again (10/10): https://192.168.99.100:20000

2018-10-19 10:08:13.135 ERROR 9952 --- [ XNIO-2 task-13] io.undertow.request                      : UT005023: Exception handling request to /app/01_hello

yml file

proxy:
  title: Open Analytics Shiny Proxy
  logo-url: http://www.openanalytics.eu/sites/www.openanalytics.eu/themes/oa/logo.png
  landing-page: /
  heartbeat-rate: 10000
  heartbeat-timeout: 60000
  port: 8080
  authentication: simple
  admin-groups: scientists
  # Example: 'simple' authentication configuration
  users:
  - name: jack
    password: password
    groups: scientists
  - name: jeff
    password: password
    groups: mathematicians
  # Example: 'ldap' authentication configuration
  ldap:
    url: ldap://ldap.forumsys.com:389/dc=example,dc=com
    user-dn-pattern: uid={0}
    group-search-base:
    group-search-filter: (uniqueMember={0})
    manager-dn: cn=read-only-admin,dc=example,dc=com
    manager-password: password
  # Docker configuration
  docker:
    cert-path: /Users/daniel.tomas/.docker/machine/machines/default
    url: https://192.168.99.100:2376
    host: 192.168.99.100
    port-range-start: 20000
  specs:
  - id: 01_hello
    display-name: Hello Application
    description: Application which demonstrates the basics of a Shiny app
    container-cmd: ["R", "-e", "shinyproxy::run_01_hello()"]
    container-image: openanalytics/shinyproxy-demo
    access-groups: [scientists, mathematicians]
  - id: 06_tabsets
    container-cmd: ["R", "-e", "shinyproxy::run_06_tabsets()"]
    container-image: openanalytics/shinyproxy-demo
    access-groups: scientists

logging:
  file:
    shinyproxy.log

#2

While the container is unresponsive, the app is working at http://192.168.99.100:20000


#3

Hi @Daniel_Tomas,

For the routing, ShinyProxy calculates a URL from the docker URL. In this case, since it’s a non-swarm docker, the calculated URL is (by default):

<docker-protocol>://<docker-host>:<assigned-port>

I.e.

https://192.168.99.100:20000

However, I believe the protocol should be HTTP in this case, not HTTPS. To override this, use the following setting:

proxy:
  docker:
    container-protocol: http

#4

Thanks :grinning:, works perfectly!