Error in getting started with ShinyProxy

Hello Open Analytics Community!

I am excited by shinyproxy, and I am attempting to run the demo app as described in the getting started page ( on a Ubuntu 16.04 digital ocean droplet. Unfortunately, when accessing the droplet via my.ip.address:8080, I receive a timed out error, and I am not sure what the problem is.

On the droplet, I had previously installed docker and I am running a static website via Hugo in a docker container using NGINX.

I then followed the getting started instructions to:

  • install Java (openjdk8)
  • edited the ExecStart line in docker.service per getting started instructions and then reloaded the daemon and then restarted docker
  • transferred the .deb file to my droplet, and installed it using dpkg -i
  • pulled the demo using sudo docker pull openanalytics/shinyproxy-demo

I then tried to access the app by pointing my laptop to my.ip.address:8080, and the connection timed out. I’ve repeated the steps above and have not received any error. Would anyone have an idea as to what I could troubleshoot?

When I run sudo netstat -peanut, I see that a PID (java) is listening on local address :::8080. Also when I run sudo service shinyproxy status, I see that shinyproxy is active with the same PID as is listening on port 8080.

A few questions I have that may be relevant.

  • The getting started file states that I should run shinyproxy by a call to the .jar file. Since I installed via .deb I didn’t think this is necessary. Is Shinyproxy running properly given that sudo service shinyproxy status states that it is active?

  • I am running nginx in a container to serve a website to my URL. Would this conflict at all with shinyproxy?

  • The application.yml lists the docker configuration url as url: http://localhost:2375. Does this need to change from the default value?

1 Like

Hello all -

I fixed the issue. I am using a digital ocean droplet, and I configured docker using the one-click app. I destroyed the droplet, and then used a basic installation of ubuntu and installed docker myself. It then worked. I assume the problem is that digital ocean installed an old version of docker.

Thanks @sbperseus, for posting your findings and solution!