Access shiny server from client side

#1

Hi I have installed shinyproxy on a CentOS 7 server using the rpm package.

I have following all the steps and I can access my apps when connecting trough http://localhost:8080 but when I tried to connect to the server remotely using the IP 69.112.130.250:8080, the page is not displayed and there is no connection

I have nginx set up with

# For more information on configuration, see:
#   * Official English Documentation: http://nginx.org/en/docs/
#   * Official Russian Documentation: http://nginx.org/ru/docs/

user nginx;
worker_processes auto;
error_log /var/log/nginx/error.log;
pid /run/nginx.pid;

# Load dynamic modules. See /usr/share/nginx/README.dynamic.
include /usr/share/nginx/modules/*.conf;

events {
    worker_connections 1024;
}

http {
    log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    access_log  /var/log/nginx/access.log  main;

    sendfile            on;
    tcp_nopush          on;
    tcp_nodelay         on;
    keepalive_timeout   65;
    types_hash_max_size 2048;

    include             /etc/nginx/mime.types;
    default_type        application/octet-stream;

    # Load modular configuration files from the /etc/nginx/conf.d directory.
    # See http://nginx.org/en/docs/ngx_core_module.html#include
    # for more information.
    include /etc/nginx/conf.d/*.conf;

    server {
        listen       80 default_server;
        listen       [::]:80 default_server;
        #server_name  69.112.130.250;
        root         /usr/share/nginx/html;
	#rewrite ^(.*) https://$server_name$1 permanent;
	}

   server {
	listen	      443;
	#server_name	69.112.130.250;
	access_log	/var/log/nginx/lifescope.access.log;
	error_log	/var/log/nginx/lifescope.error.log error;
      
        # Load configuration files for the default server block.
        include /etc/nginx/default.d/*.conf;

        location / {
	proxy_pass          http://127.0.0.1:8080/;

       proxy_http_version 1.1;
       proxy_set_header Upgrade $http_upgrade;
       proxy_set_header Connection "upgrade";
       proxy_read_timeout 600s;

       proxy_redirect    off;
       proxy_set_header  Host             $http_host;
       proxy_set_header  X-Real-IP        $remote_addr;
       proxy_set_header  X-Forwarded-For  $proxy_add_x_forwarded_for;
       proxy_set_header  X-Forwarded-Proto $scheme;
        }

        error_page 404 /404.html;
            location = /40x.html {
        }

        error_page 500 502 503 504 /50x.html;
            location = /50x.html {
        }
    }

# Settings for a TLS enabled server.
#
#    server {
#        listen       443 ssl http2 default_server;
#        listen       [::]:443 ssl http2 default_server;
#        server_name  _;
#        root         /usr/share/nginx/html;
#
#        ssl_certificate "/etc/pki/nginx/server.crt";
#        ssl_certificate_key "/etc/pki/nginx/private/server.key";
#        ssl_session_cache shared:SSL:1m;
#        ssl_session_timeout  10m;
#        ssl_ciphers HIGH:!aNULL:!MD5;
#        ssl_prefer_server_ciphers on;
#
#        # Load configuration files for the default server block.
#        include /etc/nginx/default.d/*.conf;
#
#        location / {
#        }
#
#        error_page 404 /404.html;
#            location = /40x.html {
#        }
#
#        error_page 500 502 503 504 /50x.html;
#            location = /50x.html {
#        }
#    }

}

My application.yml looks like this

proxy:
  port: 8080
  authentication: simple
  admin-groups: admins
  container-log-path: /home/jfertaj
  users:
  - name: jfertaj
    password: password
    groups: admins
  - name: jamigo
    password: password
    groups: admins
  - name: beaqui
    password: hgmd2019
    groups: scientists
  - name: fbarros
    password: hgmd2019
    groups: scientists
  - name: clara
    password: hgmd2019
    groups: scientists
  - name: avega
    password: hgmd2019
    groups: scientists
  - name: louli
    password: hgmd2019
    groups: scientists
  - name: juliorod
    password: hgmd2019
    groups: scientists
  - name: evam
    password: hgmd2019
    groups: scientists
  - name: celsa
    password: hgmd2019
    groups: scientists
  - name: miguel
    password: hgmd2019
    groups: scientists  
  docker:
    url: http://localhost:2375
    port-range-start: 20000
  specs:
  - id: 01_hello
    display-name: Hello Application
    description: Application which demonstrates the basics of a Shiny app
    container-cmd: ["R", "-e", "shinyproxy::run_01_hello()"]
    container-image: openanalytics/shinyproxy-demo
    access-groups: admins
  - id: new_app
    display-name: new APP
    description: Test of directories
    container-cmd: ["R", "-e", "shiny::runApp('/root/new_app')"]
    container-image: new_app
    access-groups: admins
  - id: hgmd
    display-name: HGMD interno
    description: Application which emulates HGMD
    container-cmd: ["R", "-e", "shiny::runApp('/root/hgmd')"]
    container-image: hgmd_filter
    access-groups: [scientists, admins]
  - id: exomes
    display-name: Exomes analysis
    description: Application to analyse exomes
    container-cmd: ["R", "-e", "shiny::runApp('/root/app_analysis')"]
    container-image: example_app2
    access-groups: admins

logging:
  file:shinyproxy.log

Any help?
Thanks