Custom URL when using nginx


#1

In the sample nginx you have

 location / {

but if we have a different location (since we may want to host other things here) then ours looks like

location /shiny {

This works fine and we are able to get to the landing page. When we try to launch an app, it looks for it in /app/appname without the shiny prefix and obviously fails. We’ve tried the proxy.landingPage and server.contextPath arguments with no luck


#2

Hi @gdc,

This shoud indeed be possible by using the server.contextPath setting, but there is a limitation: the context path must be the same before and behind the proxy. E.g.

application.yml:

server:
  contextPath: /abc

nginx.conf:

location /abc {
   proxy_pass          http://127.0.0.1:8080/abc/;
   ... 

Did you try this approach?


#3

I thought I had tried this but apparently had done something wrong… that issue is fixed thanks!