Deploy Containerised Shinyproxy with Azure Web App Services and Docker Compose

Is this possible? I have tried multiple configs in application.yml and in both dockerfile and docker compose but can’t get the app to open in shiny proxy when deploying the app in Azure due to either the docker refusing connection or directory not found error. the app works flawlessly with docker compose up in local environment with internal networking and with both app and shinyproxy containerised. Has anyone done it before or is there a guide on how to?

Thank you in advance

I am facing the same issue when deploying a containerised shiny proxy (copied the workflow from YiHui’s tutorial https://www.databentobox.com/2019/11/05/deploy-r-app-with-shinyproxy/). Followed the tutorial on Azure for cloud deployment https://docs.microsoft.com/en-us/azure/container-instances/container-instances-tutorial-deploy-app

The Shiny proxy java app works fine, able to login but opening the shiny app gives a status code 500 error

Error

Status code: 500

Message: Failed to start container

Stack Trace: A bunch of messages

Hi,

Same problem here. Stanalone java app working fine but i get an 500 Error

After inspecting i take the probable cause is that the shinyproxy container is not able to communicate with the docker daemon to lauch the shinyapp container. I think that the -v option from the run command is not exposing the unix socket.

some things to take into account are:

  1. application.yml: use the internal-networking: true

  2. in the specs section, for each app append this line container-network: name_of_the_network

Still i get the same error:

Error 500 Failed to start the container Caused by: com.spotify.docker.client.exceptions.DockerException: java.util.concurrent.ExecutionException: javax.ws.rs.ProcessingException: org.apache.http.conn.HttpHostConnectException: Connect to localhost:2375 [localhost/127.0.0.1] failed: Connection refused (Connection refused)

Well i finally found the problem:

I just simply rebuilt a shinyapp container and tested it again with the above settings and it works.

BTW i didn’t need the file in /etc/systemd/system/docker.service.d/override.conf

docker version 19.03.13