Does this actually work? Unable to do anything

I’m getting a little disheartened with this software.
I’ve followed the instructions, such as they are.
I’m running on Redhat 7 and i’ve installed the redhat docker packages.
I’ve downloaded the rpm for shinyproxy and installed it.
I’ve basically done a copy paste of the sample application.yml file
And it sometimes works, sometimes doesn’t . I can sometimes connect as far as the login page then get logged in and choose the hello world test. That crashes out with error 500, timed out waiting for container.
Where I can quite clearly see in the logs that the container spun up and is waiting on 3838
If I follow the troubleshooting guide and run the command independently, it spins up fine and works on 3838
Your proxy software just doesn’t seem to work all the time, or has an issue communicating with the docker daemon. I don’t know. But even if I crank up the debug logging on it. It still reports very little of any use to debug the situation.

This is my application.yml
proxy:
title: Open Analytics Shiny Proxy
logo-url: http://www.openanalytics.eu/sites/www.openanalytics.eu/themes/oa/logo.png
landing-page: /
#container-wait-time: 60000
heartbeat-rate: 10000
#heartbeat-timeout: 60000
port: 8080
authentication: simple
admin-groups: scientists

Example: ‘simple’ authentication configuration

users:

  • name: jack
    password: password
    groups: scientists
  • name: jeff
    password: password
    groups: mathematicians

Example: ‘ldap’ authentication configuration

ldap:
url: ldap://ldap.forumsys.com:389/dc=example,dc=com
user-dn-pattern: uid={0}
group-search-base:
group-search-filter: (uniqueMember={0})
manager-dn: cn=read-only-admin,dc=example,dc=com
manager-password: password

Docker configuration

docker:
cert-path: /home/none
url: http://localhost:2375
port-range-start: 20000
internal-networking: true
specs:

  • id: 01_hello
    display-name: Hello Application
    description: Application which demonstrates the basics of a Shiny app
    container-cmd: [“R”, “-e”, “shinyproxy::run_01_hello()”]
    container-image: openanalytics/shinyproxy-demo
    access-groups: [scientists, mathematicians]
    container-network: sp-example-net
  • id: 06_tabsets
    container-cmd: [“R”, “-e”, “shinyproxy::run_06_tabsets()”]
    container-image: openanalytics/shinyproxy-demo
    access-groups: scientists
    container-network: sp-example-net

logging:
file:
shinyproxy.log
level:
root: DEBUG

I’ve created the override.conf as described for docker
[Service]
ExecStart=
ExecStart=/usr/bin/dockerd --debug=true --log-level=debug --log-driver=journald -H unix:// -H tcp://127.0.0.1:2375

Docker is certainly listening on port 2375.
How do you actually get this thing to work??

One way to make it work is to follow the instructions carefully…if you had copied sample application.yml file (or used the default), it would work.
However, you added some options that are only needed if shinyproxy itself is run inside a container, such as internal-networking: true and container-network for the apps (as described in https://www.shinyproxy.io/configuration/#docker).

1 Like