Failed to start app

I am having trouble running any application other than the default ones.
I have tried the template but I can’t get it to work, a page with “Failed to start app” appears.

The journal shows this error:

java.lang.NullPointerException: Cannot invoke "eu.openanalytics.containerproxy.spec.expression.SpelField$String.resolve(eu.openanalytics.containerproxy.spec.ex>
    at eu.openanalytics.containerproxy.model.spec.ContainerSpec.firstResolve( ~[containerproxy-1.0.1.jar!/:1.0.1]
    at eu.openanalytics.containerproxy.model.spec.ProxySpec.lambda$firstResolve$1( ~[containerproxy-1.0.1.jar!/:1.0.1]
    at java.base/$3$1.accept( ~[na:na]
    at java.base/java.util.Collections$2.tryAdvance( ~[na:na]
    at java.base/java.util.Collections$2.forEachRemaining( ~[na:na]
    at java.base/ ~[na:na]
    at java.base/ ~[na:na]
    at java.base/$ReduceOp.evaluateSequential( ~[na:na]
    at java.base/ ~[na:na]
    at java.base/ ~[na:na]
    at eu.openanalytics.containerproxy.model.spec.ProxySpec.firstResolve( ~[containerproxy-1.0.1.jar!/:1.0.1]
    at eu.openanalytics.containerproxy.service.ProxyService.prepareProxyForStart( ~[containerproxy-1.0.1.jar!/:1.0.1]
    at eu.openanalytics.containerproxy.service.ProxyService.startOrResumeProxy( ~[containerproxy-1.0.1.jar!/:1.0.1]
    at eu.openanalytics.containerproxy.service.ProxyService.lambda$startProxy$4( ~[containerproxy-1.0.1.jar!/:1.0.1]
    at eu.openanalytics.containerproxy.service.ProxyService.lambda$action$11( ~[containerproxy-1.0.1.jar!/:1.0.1]
    at java.base/java.util.concurrent.Executors$ ~[na:na]
    at java.base/ ~[na:na]
    at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker( ~[na:na]
    at java.base/java.util.concurrent.ThreadPoolExecutor$ ~[na:na]
    at java.base/ ~[na:na]

The steps I done are the following:

  • I have cloned the github repository

git clone

  • I have built the image

docker build -t test .

  • I have added the application to the configuration
  - id: test
    display-name: Test
    container-cmd: ["R", "-q", "-e", "shiny::runApp('/root/euler')"]
    contaier-image: test

The image runs perfectly using docker run -p 3838:3838 test

More info:
shinyproxy: 3.0.1 (deb)
docker: 23.0.2
OS: Ubuntu 22.04.2
Java: 17.0.7

same problem with all 3.x shinyproxy

Hi @gmrtnz there is a type in your config block, you are using contaier-image: test instead of container-image. Therefore, ShinyProxy fails when trying to start the application. I understand that the error is not very user-friendly, we will try to improve this in the future.

Thanks @tdekoninck. The mystery has been solved. I remember that after trying multiple times it started to work but I had no idea why, I guess I corrected the typo without realizing it.