Failed to start container

Hi Team,

I am getting the following error when I deploy my app using docker and shinyproxy

Status code: 500

Message: Failed to start container

Stack Trace:
eu.openanalytics.containerproxy.ContainerProxyException: Failed to start container
at eu.openanalytics.containerproxy.backend.AbstractContainerBackend.startProxy(
at eu.openanalytics.containerproxy.service.ProxyService.startProxy(
at eu.openanalytics.shinyproxy.controllers.AppController.getOrStart(
at eu.openanalytics.shinyproxy.controllers.AppController.startApp(
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at java.base/
at java.base/
at java.base/
at org.apache.http.conn.socket.PlainConnectionSocketFactory.connectSocket(
at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(
… 30 more

I already went thru the troublesshoting options here

and my app works fine when I run it manually the manual deploy command

sudo docker run -p 9996:9996 radioimagen5 R -e 'options("shiny.port"=9996,"");rappExt::run_app()'

this is what I have in my application.yaml:

hide-navbar: false
title: Radioimagen Web App
port: 9996
template-path: ./templates/1col
authentication: none
container-wait-time: 90000
heartbeat-rate: 10000
heartbeat-timeout: 20000
landing-page: /app/radioimagen5/
container-log-path: ./container-logs


  • name: robertoromo
    password: pass
    groups: all

cert-path: /home/none
url: http://localhost:2375
port-range-start: 20000


  • id: radioimagen5
    display-name: Radioimagen Web App
    description: Application which demonstrates the basics of a Shiny app
    container-cmd: [“R”, “-e”,“options(‘shiny.port’=9996,‘’);rappExt::run_app()”]
    container-image: radioimagen5
    port: 9996


@robertoromor: from my experience, such error message is when shinyproxy is unable to communicate via port 2375 internally.

This blog post by @Luke_Singham helped me a lot. For Ubuntu system, follow his guide to set the docker config in /lib/systemd/system/docker.service.

For RHEL, the config that works for me is setting the ExecStart as follow: ExecStart=/usr/bin/dockerd-current -H unix:// -D -H tcp://

For other Linux distro, shinyproxy’s guide has the corresponding config string to use.

A key piece I find is specifying the correct path for the docker engine, in my case /usr/bin/dockerd-current.