Host name may not be null after upgrading to 0.9.3


#1

I just upgraded from ShinyProxy 0.8.4 to 0.9.3 and am now getting an error when I try and launch my Shiny App. The error is:

2017-07-21 09:25:57.046 INFO 24 — [ XNIO-2 task-1] c.s.docker.client.DefaultDockerClient : Creating container with ContainerConfig: ContainerConfig{hostname=null, domainname=null, user=null, attachStdin=null, attachStdout=null, attachStderr=null, portSpecs=null, exposedPorts=[3838], tty=null, openStdin=null, stdinOnce=null, env=[SHINYPROXY_USERNAME=d2ONJkPJdcZXLFFaEmeANnOXy6iDQ1CyLNQAW5qS, FLAMINGO_DB_IP=10.10.0.97, FLAMINGO_DB_NAME=Flamingo_Integration, FLAMINGO_ENVIRONMENT=Integration, FLAMINGO_DB_PORT=1433, DOCKER_HOST_IP=, FLAMINGO_DB_USERNAME=Integration, FLAMINGO_DB_PASSWORD=Integration, FLAMINGO_API_PORT=8000, FLAMINGO_DB_DRIVER=NwSQL, FLAMINGO_PORT_RANGE_START=20000], cmd=[R, -e shiny::runApp(’/root/BFE_RShiny’)], image=coreoasis/flamingo_shiny:FLAMINGO_0_0_228_0, volumes={}, workingDir=null, entrypoint=null, networkDisabled=null, onBuild=null, labels=null, macAddress=null, hostConfig=HostConfig{binds=[/home/oasis/FlamingoShare/Integration/Files:/var/www/oasis/Files], blkioWeight=null, blkioWeightDevice=null, blkioDeviceReadBps=null, blkioDeviceWriteBps=null, blkioDeviceReadIOps=null, blkioDeviceWriteIOps=null, containerIdFile=null, lxcConf=null, privileged=null, portBindings={3838=[PortBinding{hostIp=0.0.0.0, hostPort=20000}]}, links=null, publishAllPorts=null, dns=null, dnsOptions=null, dnsSearch=null, extraHosts=null, volumesFrom=null, capAdd=null, capDrop=null, networkMode=null, securityOpt=null, devices=null, memory=null, memorySwap=null, memorySwappiness=null, memoryReservation=null, cpuPeriod=null, cpuShares=null, cpusetCpus=null, cpusetMems=null, cpuQuota=null, cgroupParent=null, restartPolicy=null, logConfig=null, ipcMode=null, ulimits=null, pidMode=null, shmSize=null, oomKillDisable=null, oomScoreAdj=null, autoRemove=null, pidsLimit=null, tmpfs=null, readonlyRootfs=null, storageOpt=null}, stopSignal=null, healthcheck=null, networkingConfig=null}
2017-07-21 09:25:57.074 ERROR 24 — [ XNIO-2 task-1] io.undertow.request : UT005023: Exception handling request to /app/BFE_RShiny

org.springframework.web.util.NestedServletException: Request processing failed; nested exception is eu.openanalytics.ShinyProxyException: Failed to start container: java.util.concurrent.ExecutionException: javax.ws.rs.ProcessingException: java.lang.IllegalArgumentException: Host name may not be null
at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:982) ~[spring-webmvc-4.3.7.RELEASE.jar!/:4.3.7.RELEASE]
at org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.java:861) ~[spring-webmvc-4.3.7.RELEASE.jar!/:4.3.7.RELEASE]
at javax.servlet.http.HttpServlet.service(HttpServlet.java:687) ~[javax.servlet-api-3.1.0.jar!/:3.1.0]
at org.springframework.web.servlet.FrameworkServlet.service(FrameworkServlet.java:846) ~[spring-webmvc-4.3.7.RELEASE.jar!/:4.3.7.RELEASE]

Is there a setting that needs to be added to application.yml?


#2

Hi @mpinkerton,

Some changes have been made to the yml layout between those versions, but there are no new mandatory settings.

What is the value of your shiny.proxy.docker.url setting?