Installing rpm of ShinyProxy 2.2.0-1 over 2.1.0-1 failing


#1

I have a server running version 2.1.0-1 of ShinyProxy which I installed using the rpm for CentOS/RHEL. I just now downloaded the 2.2.0-1 rpm, stopped my current ShinyProxy service and tried to install it, upon which I get the following error:

[root@shinyproxy ~]# yum install /tmp/shinyproxy_2.2.0_x86_64.rpm 
                                                    
Loaded plugins: fastestmirror, langpacks
Examining /tmp/shinyproxy_2.2.0_x86_64.rpm: shinyproxy-2.2.0-1.x86_64
Cannot install package shinyproxy-2.2.0-1.x86_64. It is obsoleted by installed package shinyproxy-2.1.0-1.x86_64
Error: Nothing to do

What is the “correct” way to upgrade ShinyProxy? It doesn’t seem that I can do it like I would normally do for all other packages.


#2

Hi @ClusterAdmin,

Sounds bizarre indeed. We will investigate. Thanks for reporting.

Best,
Tobias


#4

Any luck tracking down the error?