Issue with shinyproxy user input data storage

I have developed a solution and decided to use shinyproxy.

I have the following problem:

A user needs to capture data on the solution, which must be stored and updated on the database for all users accessing the solution, I used SQLite and with R for this.

Now when I log in and capture data, it saves, but when i log in with a different user I dont get to find the captured data.

The problem is that saving data doesnt seem to be saving on the docker image, why is this and how can I go about remedying it?

For problem testing purposes:

Solution link:

Data Capturer user:


password: Fyyds7zF.

Admin user:


password: prupre35A2.


Inside the solution, if you go to the data management tab, data entry and then right click on an table and insert a new row, click save changes, it must safe new changes to the docker image but its only temporarily doing so, the other user cant see the changes made.

My solution is going live Wednesday 18 July 2018.

Your assistance would be greatly appreciated as this is critical.

Hi @Brian_Maja,

The design of ShinyProxy is to launch ‘private’ containers for user sessions.
This means that each user gets their own container with an R process running in it; users cannot see or access each other’s processes and/or data.

If you want to share data, take a look at volume mounting via the docker-volumes setting:
This allows you to mount the same folder in all containers. I am not very familiar with SQLite, but maybe you can set it up to use shared database files on the mounted folder…

Hi @fmichielssen

Thanks for the response, I tried attempting this but I am seriously getting lost, is there perhaps a tutorial I can use which clearly shows how to host a your shiny application on shiny proxy with persistent data?

Something like the euler tutorial just with the docker-volumes in use.

Fundamentally I just want the data to be stored when the user clicks save data

Hi @fmichielssen

Managed to solve the problem:

1 Like

Hi @Brian_Maja,

Thanks for the update, good to hear it was solved!