Landing page loading from cache causing app not to load

Hello, we are using ShinyProxy 2.3.0 on Kubernetes to run an app and have recently encountered the problem of a page not loading because it receives a 303 error. When the app is reloaded the Kubernetes pod is killed and the app cannot load - this is a known behavior however after the pod is restarted and the user tries to reload the page it still receives a 303 Error.

To debug it, I looked in the network tab in the dev tools in Firefox and Chrome and see that jquery.min.js and bootstrap.min.js are both being loaded from the cache, if I do a hard refresh (shift+ctrl+r) the page reloads ok or if I disable the cache in the dev tools in the browser it will also load without the 303 error. I have tried adding ?cache=false as a query parameter to the end of the landing page URL to avoid JQuery using the cache but this hasn’t solved the issue. I do not see anything in the change logs for ShinyProxy >2.3.0 that would indicate this is some known bug that has been fixed and I see that ShinyProxy doesn’t deal directly with caching (https://support.openanalytics.eu/t/how-does-caching-work/1248)

Has anyone run into this issue before?