My app runing but cat not access files

Hi all,
here is my problem:
I made simply shinyproxy and uploaded my own app, it works fine locally, on my computer(windows 10) and it can access files means it can write a “csv” file, it can read the “csv” file and it can show it to me.
but when it comes to shinyproxy, it did not working, the path my app use is relative path, like “pr.csv” or “base/baseset.csv”, when I press “write” in my app with shinyproxy, it goes well but I did not find “pr.csv” write which should be written new data, and when I press “show me” in my app, the app goes down, it stopped. I checked the shinyproxy.log but it weird did not logging from 26 February which now is 3 March.
part of Dockerfile

cat ~/shiny_klot/shinyproxy-template/Dockerfile
#RUN mkdir /root/euler
RUN mkdir /root/prapp
#COPY euler /root/euler
COPY prapp /root/prapp
COPY /usr/lib/R/etc/

part of application.yml file

  • id: prapp
    display-name: PR 0.12
    container-cmd: [“R”, “-e”, “shiny::runApp(‘/root/prapp’)”]
    container-image: openanalytics/shinyproxy-template

I rebuilded the docker image openanalytics/shinyproxy-template several times by using(Dockfile changed, like add other users WORKING dir but not solved the problem):

sudo docker build -t opeanalytics/shinyproxy-temlate ~/shiny_klot/shinyproxy-template/

and I restarted the docker service. no file access also.

I try to pull the image(do I need it?) it denied

sudo docker pull openanalytics/shinyproxy-template
Using default tag: latest
Error response from daemon: pull access denied for openanalytics/shinyproxy-template, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied

grateful any suggestions, thank you all.

problem solved,

  1. the file can not write caused by the container name, lost 2 words I just type it not paste it.
  2. the file read is caused by the wrong type of csv file, it must by UTF-8 and no quotation marks, I rebuild them and the app runs well.
    simple and low-level mistake.
    Maybe I should use some tools like VSCode under windows 10? help me check it out.
1 Like