Privileged flag not working with dockerized shinyproxy


#1

Dear developers,

I’m running a dockerized instance of shinyproxy which is correctly spawning dockerized apps.

However, I’ve been running into issues with automounter for the app dockers, and I’ve noticed the app dockers do not run in privileged mode even though I set privileged: true for the ‘docker’ key in the application.yaml as well as for each of the apps.

The shinyproxy docker instance itself is running in privileged mode as I pass this flag directly to docker.

Do you have any clue why this is failing?

Thanks for any clues,

Best,

Katarzyna


#2

Hi @ksikora,

Thanks for bringing this up, it looks like a regression bug.
It should be possible to set the privileged flag on two levels:

  • Globally at proxy.docker.privileged or proxy.kubernetes.privileged
  • Per app at proxy.specs[...].container-privileged

Currently, only the latter is working as expected. We’ll fix this in an upcoming release.


#3

Hi @fmichielssen,

Thanks a lot , container-privileged did the job :+1:

Best,

Katarzyna


#4

Hi @ksikora,

ShinyProxy 2.2.2 contains a fix for this bug (and more):

https://www.shinyproxy.io/downloads/

Thanks again for reporting!

Best,
Tobias