Shiny proxy not working after latest docker upgrade


#1

Hello,

We have updated to the latest version of docker EE: Docker version 17.06.1-ee-2, build 8e43158

After the upgrade, we have followed the instructions: https://www.shinyproxy.io/getting-started/

Afterwards, we get the following error:
Error

Status code: 500

Message: Failed to start container: java.util.concurrent.ExecutionException: javax.ws.rs.ProcessingException: org.apache.http.conn.HttpHostConnectException: Connect to 172.18.0.1:2375 [/172.18.0.1] failed: Connection refused (Connection refused)

Is the following line: ExecStart=/usr/bin/dockerd -H unix:///var/run/docker.sock -D -H tcp://127.0.0.1:2375
not current anymore, or not working with the newest version of docker?

Thanks

Marek


#2

I’m experiencing the same issue with

Docker version 17.06.2-ce, build cec0b72
16.04.3 LTS (Xenial Xerus)

#3

Changing ExecStart variable in the /lib/systemd/system/docker.service file fixed the issue for me.

ExecStart=/usr/bin/dockerd -H fd:// -D -H tcp://127.0.0.1:2375


#4

I faced the same issue. Editing the /lib/systemd/system/docker.service as suggested by Luke_Singham fixed it. Thanks a lot!


#5

Thanks @marekdabek for the report, @Luke_Singham for the fix and @Claas for the confirmation. I have updated the getting started guide at https://www.shinyproxy.io/getting-started/#docker to be in line with the latest Docker versions.


#6

Somehow my Centos 7 with Docker version 17.09.0-ce only works when the old setting was presented.