Shinyproxy 3.0.0 - K8s - container-cmd

After upgrading to ShinyProxy 3.0.0 on kubernetes we got a issue with container-cmd
Example yaml:
container-cmd: [“R”, “-q”, “-e”, “options(shiny.port=3838,‘’); ablanor::run_app()”]

This will split the argument after the comma in the port number (shiny.port=3838,)
This worked fine in earlier versions of shinyproxy
Example output from kubectl describe:
options(shiny.port=3838‘’); ablanor::run_app()

Example output:
kubectl -n shiny logs sp-pod-dcb61d5e-8b61-46ed-a953-88a91674ff19
ARGUMENT ‘‘’);’ ignored
ARGUMENT ‘rapadm::run_app()’ ignored


Error: unexpected end of input
Execution halted

Looks like splitting it without comma is a workaround
container-cmd: [ "R", "-q", "-e", "options(shiny.port=3838); options(''); rapadm::run_app()"]

Hi, thanks for checking out the latest release!

I could reproduce the error and fixed it right away. You can try using the image: openanalytics/shinyproxy-snapshot:3.0.1-SNAPSHOT-20230303.105513

We will do a patch release next week. Thanks for reporting the bug.

Thanks. I can confirm the snapshop is working as expected.

1 Like

I just released ShinyProxy 3.0.1 which fixes this.