ShinyProxy doesn't load after reboot


#1

Everytime I reboot my server (a Google Compute Engine VM), ShinyProxy doesn’t load properly and I have to restart it.

Performing sudo systemctl status shinyproxy.service shows:

shinyproxy.service - ShinyProxy
Loaded: loaded (/etc/systemd/system/shinyproxy.service; disabled; vendor preset: enabled)
Active: inactive (dead)

Doing a sudo systemctl restart shinyproxy.service gets the package running again. I have tried in both Ubuntu 16.04 and 18.04. I am using a nginx reverse proxy. Here is my java version:

openjdk version "1.8.0_181"
OpenJDK Runtime Environment (Zulu 8.31.0.1-linux64) (build 1.8.0_181-b02)
OpenJDK 64-Bit Server VM (Zulu 8.31.0.1-linux64) (build 25.181-b02, mixed mode)

My /var/log/syslog can be seen here: http://www.emillarsen.com/syslog. Could it be that shinyproxy fails to load because java or docker have not finished loading first? I have installed ShinyProxy from the .deb file. My logging in application.yml is set to:

logging:
  level:
    org.springframework.security.ldap.authentication: DEBUG
    org.springframework.security.ldap.userdetails: DEBUG
  file:
    shinyproxy.log

But the shinyproxy.log file is not created.


#2

Hello,

sorry for the late reply. By default, since we don’t want to enforce a persistent behaviour, the choice is left to the user the permanently enable the shinyproxy service in systemd.

Consequently, to have it automatically started after a reboot, please do:
sudo systemctl enable shinyproxy

Should you want to check if the service is already enabled, run:
sudo systemctl is-enabled shinyproxy

As a side note, shinyproxy service just waits for network service to be ready. If that service errors, it might cause issue to have shinyproxy properly booted up.

Hpoe it helps. Should you have additional issue, do not hesitate to ping us again.