Shinyproxy (in docker) and auto nginx proxy


TLDR: Using Nginx auto proxy (with letsencrypt) and Shinypoxy (docker). Everything works fine over https but app assets don’t load correctrly over https. Help appreciated :slight_smile:

I have been playing around with using ShinyProxy (in docker) behind auto nginx-proxy. Everything works fine over http but when I switch to https (with letsencrypt)the shiny app assets stop loading. Example app here

I’ve tried adding the proxy config recommended on the main shinyproxy site as recommended by auto nginx-proxy as a custom config but that hasn’t helped. Full nginx config is here.

I previously had everything working using the recommended config and nginx in docker - so the problem is likely to lie with settings for nginx auto proxy.

Any help would be appreciated as I don’t have much Nginx knowledge and have pretty much run out of ideas (with the last idea being to roll back to manually specifying the Nginx config).


ran into the same issue. did you find a solution to this?