ShinyProxy on OSX


#1

Docker startup options
Hi,

I am trying to get shinyproxy working…

How allow connection to port 2375 on OSX?

regards,


#2

The Docker configuration parameters can be found by executing docker-machine env on the Docker host, this will return something like:

export DOCKER_TLS_VERIFY="1"
export DOCKER_HOST="tcp://192.168.99.100:2376"
export DOCKER_CERT_PATH="/Users/youruser/.docker/machine/machines/default"
export DOCKER_MACHINE_NAME="default"
# Run this command to configure your shell:
# eval $(docker-machine env)

In the docker configuration of the application.yml file, you can then use

  docker:
      cert-path: /Users/youruser/.docker/machine/machines/default
      url: https://192.168.99.100:2376
      host: 192.168.99.100
      port-range-start: 20000

HTH,
Tobias


#3

I am having trouble as well:

I am also having trouble getting this working. I can get to the the page where the apps are located, but then get errors like:

Failed to start container: java.util.concurrent.ExecutionException: javax.ws.rs.ProcessingException: org.apache.http.conn.HttpHostConnectException: Connect to 192.168.99.100:2375 [/192.168.99.100] failed: Connection refused

I have tried a number of different configurations with no luck. Here are some of things I have done along the way. I am doing this on Mac OS:

  1. Use the command: docker-machine env default to get my settings

  2. I then took the values from:

    export DOCKER_HOST="tcp://192.168.99.100:2376"

    And updated my application.yml file to:

    url: http://192.168.99.100:2375

    host: 192.168.99.100

  3. Ran the recompile of the jar file

  4. Ran the docker app: docker run -d openanalytics/shinyproxy-demo:latest

This is the simplest and seems closest to what you have suggested. I also tried changing the port on the docker run command: docker run -d -p 3838:2375 openanalytics/shinyproxy-demo:latest

Is there a step I am missing, when I look at the docker container, I see shinyproxy running saying:

shinyproxy::run_01_hello()
Loading required package: shiny
Listening on http://0.0.0.0:3838

Thanks


#4

Ok, Figured it out - Let me do this step by step:

  1. Use the command: docker-machine env default to get my settings
export DOCKER_HOST="tcp://192.168.99.100:2376"
export DOCKER_CERT_PATH="/Users/rajivshah/.docker/machine/machines/default"
export DOCKER_MACHINE_NAME="default"```
2. Update the application.yml file to:
	```      cert-path: /Users/rajivshah/.docker/machine/machines/default
      url: https://192.168.99.100:2376
      host: 192.168.99.100```
      
3. Ran the recompile of the jar file `zip -r -Zstore ../shinyproxy-0.3.0.jar *`

4. Then run the java file: `java -jar shinyproxy-0.3.0.jar` (It starts the docker containers when you click on an app)

#5

Many thanks, @rajcs4 for reporting back and glad to hear you have lift off!

For the record: if you put a customized version of the @application.yml@ in the same folder as the .jar file (using the same name, i.e. ‘@application.yml@’), the values will be picked up automatically (and overwrite the default configuration).

Best,
Tobias


#6

Trying for hours…

I really need your help…

Of course, I am trying to set up shinyproxy on mac os, but even with this solution I can’t get it work!!!

  • I followed exactly the steps mentioned here
  • shinyproxy as such is working
  • I can run the docker demo
    sudo docker run -p 3838:3838 openanalytics/shinyproxy-demo R -e 'shinyproxy::run_01_hello()'
    without any problems

But…

  • When I try to start docker via shinyproxy, Hello Application or 06_tabsets
  • than I get the following Error Message

Please can you help me?

  • Do need further information about the versions I use?
  • What else can I do to find a working solution?

Thank you very much for your help!!!

Best regards,
Chris


#7

here comes the rescue, :grinning::grinning: check it out, it should be helpful