[Solved] Euler example: Container unresponsive


I’ve worked my way through the “Getting Started” part of the documentation, and the examples from the openanalytics/shinyproxy-demo image work fine.
Then I moved on to the “Deploying App” part. The docker image compiled successfully and when I run it manually I can access the app via browser. But when trying to load it through Shinyproxy I only get the container unresponsive message and ultimately “Container did not respond in time”.
I have tried increasing the timeout with container-wait-time. That didn’t help.

I simply added the app to the default application.yml using
- name: euler
docker-cmd: [“R”, “-e”, “shinyApp::(’/root/euler’)”]
docker-image: shinyproxy-template
groups: scientists
Other that that I simply copied the default file. (“shinyproxy-template” is what I called the docker image)

At this point I really don’t know what else to try, I hope someone here can spot my mistake.

is there a typo in your docker-cmd?
It should be docker-cmd: ["R", "-e shiny::runApp('/root/euler')"]

wow. I must really have been tired.
Of course it has to be shiny::runApp()!
Using “R”,"-e","…" seems to be fine. I’m guessing in YAML [a,b,c] is a list, and at least here it is parsed with whitespace as separator.
Thank you very much!

p.s. I’ve changed the title to include [SOLVED]. Do I need to close the topic somehow?