Status code 500 : Container did not respond in time

Hello,

I would like to run an R Shiny application via Shinyproxy locally first.
My Application is functional, after docking it, it still works with a docker command.
I created a ‘shinyproxy’ image and launched the container but I get the following error message when I click on the application name:

# Error

**Status code:**  500

**Message:**  Container did not respond in time

I suspect a problem related to the different ports … notions that I don’t master.

The dockerfile of shiny app looks like :

image

with the following Rprofile :

local({
   options(shiny.port = 3838, shiny.host = "0.0.0.0")
})

The shinyproxy application.yml looks like :

proxy:
  port: 8080
  authentication: simple
  admin-groups: admins
  users:
  - name: jack
    password: password
    groups: admins
  - name: jeff
    password: password
  - name: MTB
    password: password
    group: admins
  docker:
      internal-networking: true
  specs:
  - id: shiny_test
    display-name: Shiny Test
    description: This is a test of shinyproxy container
    container-cmd: ["R", "-e", "shinyproxy::shiny_test()"]
    container-image: shiny_app_test
    container-network: sp-net
logging:
  file:
    shinyproxy.log

What I tried is the following command :

docker run -d -v /var/run/docker.sock:/var/run/docker.sock --net sp-net -p 8080:8080 shinyproxy_container

All help is welcome

Hi Mos_Taf,

I do not see all details of your configuration and docker images names, but I would check shinyproxy log, docker ps during “starting” of container (to see if container is started or not).
Take care also on docker: settings in .yaml file. Try to use as mentioned in documentation:

cert-path: /home/none
url: http://localhost:2375
port-range-start: 20000

Also, consider calling app with
container-cmd: ["R", "-e", "shiny::runApp('/root/app_test')"]

1 Like

Indeed, that should fix the problem. You can also omit this property. In that case ShinyProxy uses the CMD of the Docker container.