Time Out Issues in Chrome

When I change the yaml to the following parameters it removes the timeout (gray out) in the Shiny app. We’ve tested this on IE and Edge, and it works perfectly. However, it does not work on Chrome, and the app times out after 10 minutes regardless of the values I use. Does anyone know why this could be or how I can fix it?

heartbeat-rate: 1
heartbeat-timeout: null

Thank you so much!

Hi @carlton.searcy,

In the current version of ShinyProxy, there is no way to really disable the heartbeat. The closest thing you can do is set both rate and timeout to a very high value.

If heartbeat-timeout is not set, it will default to 60000 (1 minute).
Setting heartbeat-rate: 1 would trigger a heartbeat every millisecond; I suspect that causes some trouble and might explain the different behaviour you are seeing in different browsers.

Hey @fmichielssen,

Thank you very much for the tips! You’re right that it is probably not smart to not use heartbeat-rate: 1. I increased both of these to larger values, but I am still experiencing the same results. The app times out at exactly 10 minutes on Chrome but does not time out (at least not for a very long time) on MS Edge.

Thank you so much for your help!

Hi @carlton.searcy,

I’m not sure why the behaviour would be different in Chrome vs Edge.
Some things that might be worth checking:

  • Does ShinyProxy log a heartbeat timeout? Is there a “Releasing inactive proxy” statement in the logs?
  • Is there a reverse proxy in front of ShinyProxy, with a read timeout set?
  • Is the app idle when you test it, or are you using it actively?