Unable to access my shiny app


I am really getting tough time to have my application run on ShinyProxy and have wasted hours and hours. After receiving this error: Message: Container did not respond in time I decided to first directly run the docker and see if application is working and this is where I got stuck. I’ve following lines at the end of Dockerfile:

CMD [“R”, “-e”, “shiny::runApp(’/root/imports’, port=3838)”]

And then I run the docker with this command: sudo docker run -p 3838:3838 aamir/imports

I can see everything running fine while monitoring console and see this message:

Listening on

However, I am unable to access the app from browser. I tried curl command got this error: Empty reply from server

I also tried launch.browser=FALSE parameter while running shiny app but nothing works.

I’ll be thankful if someone can give me any hint why this is happening.

Please try adding shiny.host = "" to your runApp command, and see also https://www.shinyproxy.io/deploying-apps/.

Thanks a lot. It worked.

Now I am getting ‘Container unresponsive’ error when it (shinyproxy) tries to connect to http://localhost:3838 (as per ShinyProxy console).

normally it should not connect to port 3838, but rather to a port from a port-range (default 20000)…so maybe something is wrong with your configuration file (application.yml).