Using Port 80 Instead of Port 8080


#1

Hi everyone,

I’m setting up Shinyproxy on Ubuntu 16 — everything is working beautifully. I’m accessing it via port 8080, and I want to use port 80 instead (so the url doesn’t require a port).

Whenever I change the port in the application.yml file it complains that port 80 is already in use and shinyproxy won’t run.

Any ideas?

Thanks!


#2

Nevermiiiind of course it was the very next thing I tried that worked perfectly. Feel free to close this thread.

For anyone else who’s running into this:

  1. sudo apt-get install nginx to install nginx.
  2. sudo vim /etc/nginx/sites-enabled/default
    Go to where it says location / {... and add the following between the opening and closing {}'s:
    proxy_pass          http://127.0.0.1:8080/;

    proxy_http_version 1.1;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection "upgrade";
    proxy_read_timeout 600s;

    proxy_redirect    off;
    proxy_set_header  Host             $http_host;
    proxy_set_header  X-Real-IP        $remote_addr;
    proxy_set_header  X-Forwarded-For  $proxy_add_x_forwarded_for;
    proxy_set_header  X-Forwarded-Protocol $scheme;
}

This is also covered in more detail over here -> https://www.shinyproxy.io/security/#https-ssl-tls