Wicked Problem with Keycloak


#1

My skill level is between beginner and intermediate using docker, dokku, server setups, Shiny and about (lifelong?) intermediate with R. I have tried using the keycloak docker image and keycloak examples docker image. Both launch and continue to run on localhost. However I can not login to the app to familiarize myself with the process of authentication. I have tried using both user/passwords set up automatically by the image creators as well as passing environment variables myself, “docker run -e KEYCLOAK_USER=testuser -e KEYCLOAK_PASSWORD=testpassword -e DB_VENDOR=H2 jboss/keycloak”. The error given each time is invalid username or password.

What elementary thing am I missing?


#2

Figured out the problem but not the full solution yet. Was surprised to find out the .jar file for shinyproxy is running in the background as a service (must have forgotten). I believe it was masking the keycloak demo app I was trying to log into.


#3

Yes, that was it. Once I stopped service and relaunched keycloak examples docker image, no problems getting into app.