Long initialization time with v3.0.1


First thanks to the team for developping such a convenient shiny app deployment solution.

I have an app in production with kubernetes on GCP and using v2.6.1. The typical start time of the app after login is 10 seconds.

I try to switch to v3.0.1 with the same configuration, including the application.yml and only changing the shinyproxy jar version.
The app is not starting and I get the usual message “Failed to start container”.
So I added container-wait-time: 90000 to the yml.
Now the app is starting but it takes nearly 3 minutes !
The shinyproxy container log says “Container unresponsive, trying again (37/55)”, incrementing every 7 seconds, and finally I get the “Proxy activated” log message.

Would you have an idea why it takes so long with the new v3.0.1 version ? Is there a parameter wrongly set up in the yml for instance ?

Thanks in advance for your time and advice !

Hi @Sylvain_Guilbert,

I never had problem like this before, although I was busy with this “Failed to start the container” error for four days! I think I solved my problem, I hope it help you too.
when I was running docker run -p 3838:3838 image_name apparently there was no problem, also I couldn’t access the application on the browser on any port. when I was running that I was getting this: listen
it supposed to be though! The solution is the way you call the application in the application.yml to force it go to host and port 3838. I added the host and port and it worked. something like this:

container-cmd: [“R”,"-e",“shiny::runApp(’~/yourappfolder’,host=‘’,port=3838)”]

The rest of the application.yml doesn’t need a change and I don’t think we need any other setting to make it work.

take care,


Thanks @Mehrdad_Varedi

My app is a package developed with Golem.
I start the app with

container-cmd: ["R", "-e", "options('shiny.port'=3838,shiny.host='');myapp::run_app()"]

In the pod log I indeed have Listening on

This works fine in v2.6.1 but takes very long in v3.0.1, and again the only difference between my two tests is the jar file.